nanmi-overlay

nanmi's Gentoo overlay
git clone git://xn--q9jzb1c.xn--q9jyb4c/nanmi-overlay
Log | Files | Refs | README

gomuks-9999.ebuild (684B)


      1 # Copyright 2021 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit golang-build
      7 
      8 DESCRIPTION="A terminal based Matrix client written in Go"
      9 HOMEPAGE="https://github.com/tulir/gomuks"
     10 
     11 if [[ "${PV}" != 9999 ]] ; then
     12 	SRC_URI="https://github.com/tulir/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
     13 	S="${WORKDIR}/${P}"
     14 	KEYWORDS="~arm64"
     15 else
     16 	inherit git-r3
     17 	EGIT_REPO_URI="https://github.com/tulir/${PN}"
     18 fi
     19 
     20 LICENSE="AGPL-3"
     21 SLOT="0"
     22 IUSE="+encryption"
     23 
     24 DEPEND="encryption? ( dev-libs/olm )"
     25 RDEPEND="${DEPEND}"
     26 BDEPEND="dev-lang/go"
     27 
     28 src_compile() {
     29 	use encryption || export CGO_ENABLED=0
     30 	go build
     31 }
     32 
     33 src_install() {
     34 	dobin ${PN}
     35 }